I might be the only one looking at this post. I did not have any errors when installing this firmware. Nortek is unlikely to answer any questions until the final release of 3.1 occurs. I'm assuming since it was pulled, it wasn't meant to be posted on the website yet.
Are you still at 3.0.1 or 3.0.2? Or did it actually install 3.1 and still give you this error?