Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Firmware update successful.... but not really

  1. #1

    Angry Firmware update successful.... but not really

    I have a 2gig system with a Control Panel and a TS1. I bought second TS1 to add after a year. The original 2 panels were running v. 1.9.X of the firmware and working just fine. The new one I bought was running 1.10X. So I thought to myself, "self, this is easy. Update the to older panels to 1.10X and everything will be fine.

    Well, the updates ran fine, the units all report having 1.10X firmware, but the first hint that something was wrong was when I brought the system back up, and powered up the old TS1, it didn't find the CP. I checked the setup in the CP, and the TS1 id was reset to (1).

    So next, my self says "no big deal, just re-pair them and we'll be good to go". So I reset the TS1, got the "unpaired" startup screen, and tried to pair them. No joy. So I took the new TS1 and tried it. Also nothing.

    So now I have 2 questions.
    1. Does anyone have any suggestions
    2. Is there any harm in re-flashing 1.9X to the panel and both TS1's?

    Any help is appreciated.

  2. #2
    Senior Member
    Join Date
    Feb 2014
    ...checked the setup in the CP, and the TS1 id was reset to (1).
    The installed TS1 should be keypad Id 1

    Q4 (04) 1-4, zones 59-62 are the rf keypads and TS1's. In my case, TS1 is keypad 2, zone 60, Device ID is 1


    Assuming you properly and successfully flashed the firmware to each device, and that you didn't damage the XCVR2 when connecting the USB JB connector in process, then let's troubleshoot.

    Go!Control panel and all TS1's are now running firmware version 1.10? You properly installed CP_V1.10en/CP_V1.10.1en on main panel, and independently updated the TS1_V1.10_English_10176d firmware manually with usb cable and TS1 4pin adapter on each TS1 ?

    Main panel firmware

    TS1 firmware
    Updating firmware should not have affected the programming/pairing of the original TS1 to panel.

    The inability to then pair the new TS1 to panel, indicates something is wrong perhaps with either firmware or XCVR2

    You need to provide more info/screenshots, of the firmware version on main panel and both TS1's, also programming screen for existing TS1, and remove/reseat the XCVR2 transceiver. If you damaged the XCVR2/sqiggly antenna the TS1's will not function/communicate with panel.

    If you cannot see the firmware on TS1, then I suggest that after you verify the main panel is running 1.10 or 1.10.1, that you connect the update cable/TS1 4 pin adapter to each TS1 and reflash the firmware, verify it is successful. You cannot update the TS1's from the main panel anymore following firmware 1.9.6.


  3. #3
    Senior Member
    Join Date
    Feb 2014
    Post above edited/updated

  4. #4
    Thanks for the reply. I'll check when I get back, but I'm fairly certain the firmware updates went fine, and each panel will come up and shows the correct firmware versions. I have not re-checked the XCVR2. I occurred to me after I shut down last night that this might have gotten dislodged in the shuffling around.

    I have a fair amount of experience with electronics installation and repair in general, and computers (flashing firmware and such) as well. I went according to the instructions accompanying the firmware updates, and everything seemed to go as described.

    I'll post again after I check the transceiver to see if it's OK.

  5. #5

    More info..

    Here are photos of the version screens for the panels. I checked the Xcvr module, and it isn't loose. I re-seated it anyway and rebooted the system. No change.

    Click image for larger version. 

Name:	20140928_154456611_iOS.jpg 
Views:	266 
Size:	91.1 KB 
ID:	6
    Click image for larger version. 

Name:	20140928_154514146_iOS.jpg 
Views:	285 
Size:	87.5 KB 
ID:	7

    I'm not sure how I would have damaged the radio module, but it's anything's possible, I suppose. I'd like to eliminate other options first, but this seems like a basic communication issue.

  6. #6
    Senior Member
    Join Date
    Feb 2014
    Are any keypads/TS1's programmed in Q4?. Check programing. If so, remove from programming before trying to pair

  7. #7
    Join Date
    Oct 2014
    Columbus, OH
    I agree with rive. I would definitely make sure to completely remove all programming that was associated with the TS1s in Q4, exiting system configuration, then going back in and trying to pair them again. I've never heard of a scenario where the firmware update makes the TS1 impossible to learn in.

  8. #8
    OK, so I'm still stuck. I replaced the Xcvr module, no change. I removed all of the entries in Q4 (I had a TS1 as the first entry, then a PAD1-345 keypad as the second. I don't see a way to "delete" the entries. I disabled them, then saved the changes, then went back in to try and get a TS1 to go into the first slot. Still no change.

    Is there a way to actually "delete" an entry that I'm just not seeing?

    Should I try and re-flash all the units? They seem to be working properly except for not pairing. The CP is working otherwise. No programming was lost during the update.

  9. #9
    Senior Member
    Join Date
    Feb 2014
    You cannot learn a TS1 to the panel that is already learned/programmed as an existing keypad in Q4. You must unlearn it/remove it from programming. Disabling it will not help you.

    See instructions for unlearning a TS1:

    If after you unlearn/remove it from the Q4 keypad programmimg, you still cannot learn it. You may need to replace the XCVR2. If you were not careful when connecting the update cable, you may have damaged it at the swiggly antenna (which would account for the issues you report)

    A new 2GIG XCVR2 345/900mhz bi directional transceiver runs approx $20 new Here.

  10. #10
    OK, 2 things.

    First, I replaced the XCCVR2 with a new one, so unless I have 2 bad radios, the problem is something different. The fact that it started after flashing the panels leads me to believe the problem is in the software, but it sure behaves like a hardware failure. How likely is it that the new radio I ordered is bad as well?

    Second, when I follow the procedure to unlearn a panel, which is simply to change it to "unused" and save/reboot, it appears to wipe everything about the entry except the name I had given it. Is that normal?

    I have unlearned all panels in 04 at this point. After doing that and saving/rebooting, I still can't get it to pair with either my old panel or the new one.

    I tried re-flashing both the CP and the TS1, still nothing.

    I'm truly stumped at this point. In my normal debugging process for this kind of thing, the next step I'd take (assuming I have no way to test the radio module, which I don't) would be to reset the entire CP to factory and try to pair a panel. I'm hoping someone has a better idea of what to do next.

    Once again, all help is appreciated.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts